Vodafone TV no longer works

New Poster
Posts: 1
Registered: ‎02-09-2020

Vodafone TV no longer works

by LeighAlbert New Poster
Message 1 of 1 (174 Views)

Hi there,


I had been looking around for a replacement for sky for a few months now as the costs were getting pretty steep.  I also wanted to be able to stream, so I sussed out Vodafone TV and it had most of the apps I was needing (free to air, streaming, possibility of sky channels etc.) and I didn't have to be tied down to another subscription if I couldn't afford it.  So after viewing a number of views and seeing majority of the issues were in 2018, I decided to give it a go.  Wandered down to Warehouse stationary and picked it up.  Was REALLY simple to use and it worked a real treat.  I've now had it for four weeks, and now it just no longer works...


About a week ago, I noticed that although the internet was working fine, the free to air channels wouldn't work anymore (network error) but I could stream Netflix etc. no problem.  So I followed the instructions and two days ago, began with the first of 13 hard resets.  At first it worked okay and then when it came to typing in the network password, the highlighted letters would skip, wouldn't allow to me select letters or uppercase them, eventually completely freezing and couldn't get it working again.


I rang Vodafone tonight and after speaking to two people and being placed on hold for 29mins I couldn't stay on the phone, because the dude on the other end never got back to me! 


So to recap: 

1.  Brought a brand new Vodafone TV four weeks ago, ack, don't have an account.

2.  Worked well for four weeks, now dead in the water.

3.  Have reset it 13 times and no go.

4.  Attempted to reach out to technicians, they put me on hold for 30 mins and never came back (great service guys! cheers!)


So, can anyone tell me what I can do to possibly fix this and/or, can I get a refund for this product if its faulty and refuses to work?


Thanks all,



  • 0 Replies
  • 19w ago
  • 0 Kudos
  • 1 Contributor