Read Me: HG659 Port Forwarding

New Poster
Posts: 1
Registered: ‎19-09-2016

Re: Read Me: HG659 Port Forwarding

by RyanMcSweeney New Poster
Message 41 of 46 (6,992 Views)

Checking with , every port said "error, cannot access" after following the instructions

New Poster
Posts: 1
Registered: ‎30-09-2016

Re: Read Me: HG659 Port Forwarding

by thecrop New Poster
Message 42 of 46 (6,952 Views)

I am having the same problem. tried a couple of port checking sites and both said port closed or connection refused


Starter Poster
Posts: 3
Registered: ‎13-02-2017

Re: Read Me: HG659 Port Forwarding

[ Edited ]
by Necropants Starter Poster
Message 43 of 46 (6,562 Views)

Save yourself a headache and buy a better router.

There is a reason why these things are free.


1. They drop port forwarding rules at random. (seen this happen on 3 different units)

2. You cannot port forward anything attached to a Wifi station, as the actual device never appears in the routing table.

3..... and even when it works the port forwarding interface is godawful, and unnessesarily convoluted.

Starter Poster
Posts: 2
Registered: ‎18-12-2017

Re: Read Me: HG659 Port Forwarding

by DB2017 Starter Poster
Message 44 of 46 (5,652 Views)

Hi EX-TimA


We are trying to connect an Fermax IP intercom system through the Vodafone HG659 modem.

We need the following ports open.



***HTTP server for QR code : Port 80 TCP

***Strongswan (VPN) : Port 68 UDP

***Internet Key Exchange (IKE) : Port 500 UDP

***Transversal NAT : Port 4500 UDP


The only one we can’t get open is port 68, is there any reason why this is?


We have also tried using the HG659 as a bridge mode and used our own D-link modem to get the Fermax IP intercom connected. This worked, however it disconnected the SIP phone connection, not good.


Is there anyway around these problems we are experiencing.


Does Vodafone have a more advanced modem that would solve our problems?


Could Vodafone have the sip connection diverted to household cell phones, this would mean we could use the HG659 as bridge and and still get calls!


Any help is good help at the moment, as I don’t want to be waiting on hold for a Vodafone guru for twenty minutes again!!!

Posted from Apple iPad
Starter Poster
Posts: 3
Registered: ‎28-01-2018

Re: Read Me: HG659 Port Forwarding

by NormanCates64 Starter Poster
Message 45 of 46 (5,512 Views)

Hi ya,

So I would like to set up port forwarding for FTP.


I have updated to the latest firmware. I am making changes as admin.


I have followed these instructions. The testing website (  can see the port and reports it's open. 


It does APPEAR to be OK.


However, when I try to connect from outside using FTP, the application just sits there and times out. I've tried WinSCP and FileZilla.


I did a test from the internet using HTTP on port 80 to connect to an IP address internally on my network, but that failed with a timeout as well...


It just doesn't seem to work.


IS there any tool that can show if the request is even getting past the modem? 


This original post is 3 years old, and it looks like the OP has left Vodafone...


Any ideas? It seems like this is a relatively common problem with this modem.

Retired Staff
Posts: 3,178
Registered: ‎02-02-2013

Re: Read Me: HG659 Port Forwarding

[ Edited ]
by MikeHales Retired Staff
Message 46 of 46 (5,502 Views)



Have you looked into the SAMBA settings to ensure you enable permissions - see this HG659 modem FAQ.


Port Forwarding FAQ also.



Product Owner AI & Automated Support
Vodafone New Zealand
  • 45 Replies
  • 7y ago
  • 6 Kudos
  • 13 Contributors