Reply

Internet shows as connected, pinging addresses work, but browsing does not work

Highlighted
New Poster
Posts: 1
Registered: ‎22-05-2019

Internet shows as connected, pinging addresses work, but browsing does not work

[ Edited ]
by Isaacu New Poster
Message 1 of 5 (429 Views)

Hi,

 

After coming home this evening, my internet does not work correctly. 

I am able to do the following:

- ping Google's DNS servers (8.8.8.8, 8.8.4.4)

- ping the DNS servers that the router says it's using

- ping the gateway address that my router is using

- ping google.com's ip address
- ping the google.com domain (i.e. DNS is working)

- ping several other well known domains (i.e. facebook, youtube, etc)

- tracert on any address, and see the packets leave my local network

 

I am unable to do the following:

- browse to any website using Google Chrome or Firefox, using any device connected to the router

- browse to any website using direct ip addresses (this is not a DNS issue, clearly)

- use any network connected applications on any device connected to the router

- ping vodafone.co.nz

 

I have performed the following trouble shooting steps:

- Power cycled with a HG659

- Power cycled devices attempting to connect to the router
- Power cycled the fibre connection box

- Switched router to Vodafone Ultrahub plus

- Power cycled the Ultrahub plus

- Power cycled the fibre box when connected to the Ultrahub plus

- Turned off IPv6 on the Ultrahub plus

- Turned on IPv6 on the Ultrahub plus

- Disabled the Firewall on Windows

- Disabled the Firewall on the Ultrahub plus

- Rang vodafone customer support, where I was bounced between people who did not understand my problem, or what I meant when I was talking about "pinging google" or "DNS" 

Extra information:
- Windows 10 believes that it is connected to the internet (the "no internet connection" symbol does not show on the wifi connection)
- An Android device believes that it is connected to the internet (the "this wifi does not have an internet connection" warning does not show)

- The Ultrahub plus "Connectivity Test" believes it is connected to the internet

- The Windows 10 diagnostic utility says "website (<website address>) is online but isn't responding to connection attempts" for every website that I've tried it with

I have been advised by Vodafone customer support that I should hire a local technician to troubleshoot my issue. I don't think this is a worthwhile endevour, as I believe the issue is at Vodafone's end. 

I cannot see where to go from here.

I want to talk to someone who knows more than I do about Vodafone's network, and will be able to troubleshoot this issue from Vodafone's end. I believe there's something that's stopping me connecting properly, and I believe it's on Vodafone's end, as I am clearly connected to the internet. 

Edit: For clarity, I am posting this via a mobile hotspot - the Vodafone websites do not work when connected to my router.

Staff
Posts: 181
Registered: ‎25-11-2011

Re: Internet shows as connected, pinging addresses work, but browsing does not work

by Staff wsfinest Staff
Message 2 of 5 (423 Views)

PM sent

Starter Poster
Posts: 2
Registered: ‎07-06-2019

Re: Internet shows as connected, pinging addresses work, but browsing does not work

by mfderaadt Starter Poster
Message 3 of 5 (344 Views)

I have exactly the same problem once i upgraded to a new Acer PC and the Xubuntu upgrade 18.04.

I tried a lower connection speed 10MB/s and it seems to be more reliable. Have you found anything?

I am still not sure whether it is a hardware or software problem, or firmware in the Vodafone modem ?

Cheers

Marius

Staff
Posts: 181
Registered: ‎25-11-2011

Re: Internet shows as connected, pinging addresses work, but browsing does not work

by Staff wsfinest Staff
Message 4 of 5 (337 Views)

Hi Marius

 

Are you saying that you once had no issues at all. Then at some point of time you upgraded/changed PC's and since then you have had a issue ?

When you have a issue can you decribe it a little more please. Can you not open web pages but are able to ping anything via doamin or ip address. What modem as well please

Starter Poster
Posts: 2
Registered: ‎07-06-2019

Re: Internet shows as connected, pinging addresses work, but browsing does not work

by mfderaadt Starter Poster
Message 5 of 5 (306 Views)

HI Wsfinest

Gee, it's difficult to pick up the thread! Finally! At first I replied to your email which was sent by this system and bounced. Here is the email i wrote to you:

 

Hello wsfinest
Thank you for taking an interest in this issue. I am nearly running out of ideas.
My old PC died and i bought a new PC an Acer Veriton.
I tested the hardware when the factory installed Windows 10 was still on there. All seemed to work well. Then i installed xubuntu 18.04 and that had no issues until i loaded an upgrade. Suddenly, Firefox and Thunderbird couldn't find the network. It requires 2 to 4 reboots in the morning for the network to come right. Once it is up it performs perfectly.
The modem light of the ethernet input is flashing so i assume that the hardware is working but that the upgrade had done something. After that there were 2 more kernel updates that didn't affect this issue. I can't find anything in the Ubuntu community about this. I have attached some screendumps of network analysis.
I experimented with the network settings but nothing seemed to solve the problem. However, when i reduced the ethernet speed on the PC to 10MB/s it seems to find the network a bit easier. It now requires only 1 or 2 reboots.
Then my attention shifted to the modem, a Vodafone (Huawei) home gateway HG659 (connected to an ONT) which up to now has performed flawlessly.
My next experiment will be to, reluctantly, disable the firewall on the modem. Maybe something changed in the ethernet driver that now affects the modem?
Any ideas are welcome.
Regards
Marius

 

Can't attach the screendumps from here. If you want them please advise your email address. Haven't tried the firewall yet. PC started this morning correctly. So i'll wait and see how this develops. Cheers...Marius

Stats
  • 4 Replies
  • 29w ago
  • 430 Views
  • 0 Kudos
  • 3 Contributors