Reply

Problems sending mail

Starter Poster
Posts: 3
Registered: ‎26-09-2017

Problems sending mail

by Bingo Starter Poster
Message 1 of 6 (244 Views)

Hello there,

 

I seem to be having some issues sending emails to one of our franchisee's. They recently changed their email account and have set the old email account to forward it to their new one.

The problem is however, when I try to send mail to either address it comes back with this message:

 

Delivery has failed to these recipients or groups:

<Account>@xtra.co.nz
A problem occurred during the delivery of this message to this e-mail address. Try sending this message again. If the problem continues, please contact your helpdesk.

The following organization rejected your message: mx.xtra.co.nz.

 

Diagnostic information for administrators:

Generating server: webcloud61.au.syrahost.com

<Account>@xtra.co.nz
mx.xtra.co.nz #<mx.xtra.co.nz #5.0.0 smtp; 550 5.7.1 Message rejected due to SPF policy> #SMTP#

 

The bit I dont understand is that the failed delivery address is not their new adress or old one (i think it might be their personal email), when sending me mail through their new address the SMTP referneces their personal one. I recently sent them a message to try clarify what they are doing email wise but in the meantime it would be good to know where the problem is happening and what can be done to fix it.

 

Their old email was <account>@clear.net.nz and their new one has a custom address (info@<name>.co.nz)

 

Any help is appreciated.

Cheers

Frequent Poster
Posts: 29
Registered: ‎24-11-2012

Re: Problems sending mail

[ Edited ]
by Frequent Poster yitz Frequent Poster
Message 2 of 6 (234 Views)

So their previous email address was <account>@clear.net.nz (now forwarded) and their new address is supposed to be info@<name>.co.nz. As you mention it sounds like they have not configured their sending server correctly for their domain which is why mail from <name>.co.nz appears to be from <personal>@xtra.co.nz

 

I would just try to contact them directly on info@<name>.co.nz. You don't know whether they check their inbox at <personal>@xtra.co.nz they might just be using it for outbound mail because their ISP is Spark.

 

As for "Message rejected due to SPF policy" this will be because your own domain is not set up to be sending email originating from your web site hosted at syrahost.com. You will get this message in situations where the recipient email provider runs a strict spam filtering policy as is the case with xtra.co.nz. If you want to get this corrected talk to your website administrator.

 

 

Starter Poster
Posts: 3
Registered: ‎26-09-2017

Re: Problems sending mail

[ Edited ]
by Bingo Starter Poster
Message 3 of 6 (221 Views)

 


yitz wrote:

 

I would just try to contact them directly on info@<name>.co.nz. You don't know whether they check their inbox at <personal>@xtra.co.nz they might just be using it for outbound mail because their ISP is Spark.

 


Just to clarify, sending mail to their new email info@<name>.co.nz results in the same SPF error . Only when messaging them on <personal>@xtra.co.nz does the email get sent and recieved, I just got a reply from them so I know it works for their personal email. Ive sent them a email askingfor a more clear structure of their email settings so im hoping to figure something out soon.

 

Thanks for the quick reply Smiley Happy Ill see what I can do

Highlighted
Frequent Poster
Posts: 29
Registered: ‎24-11-2012

Re: Problems sending mail

by Frequent Poster yitz Frequent Poster
Message 4 of 6 (219 Views)

Just re-reading your initial post if you are getting SPF errors when attempting to send mail to both info@<name>.co.nz and <personal>@xtra.co.nz then it is likely info@<name>.co.nz is just a forwarding domain which they have set up to <personal>@xtra.co.nz corresponding to their current ISP.

 

Advice in last paragraph regarding contacting your website administrator still stands, it is best to get your outbound mail originating servers authenticated and whitelisted.

 

 

Starter Poster
Posts: 3
Registered: ‎26-09-2017

Re: Problems sending mail

[ Edited ]
by Bingo Starter Poster
Message 5 of 6 (213 Views)

Ill see what I can do about the whitelisting and authenticating.

 

I could be totally wrong here but my guess is that the connection between both the business emails and personal email is where the problem lies and not at our end since before the change sending emails worked fine and I can successfully email them diretcly VIA their personal email. Its only when the mail is being (what I think is) rediretced the SPF error occurs.

Frequent Poster
Posts: 29
Registered: ‎24-11-2012

Re: Problems sending mail

by Frequent Poster yitz Frequent Poster
Message 6 of 6 (179 Views)

Yes you would be correct that is another scenario that may cause the error to occur when the recipient email provider implements a strict source filtering regime.

Stats
  • 5 Replies
  • 3w ago
  • 245 Views
  • 0 Kudos
  • 2 Contributors
Kudos 101- Don't be shy, hand it out today