Reply

Huawei HG659 Bridge Mode

Highlighted
Regular Poster mmd
Regular Poster
Posts: 16
Registered: ‎17-11-2011
Accepted Solution

Huawei HG659 Bridge Mode

by Regular Poster mmd Regular Poster
Message 1 of 78 (28,682 Views)

Hi

 

After spending countless hours playing with the settings on the Huawei VDSL router Vodafone provided, and then troubleshooting using a second and third wireless router for comparison purposes, I have come to the conclusion that the Huawei is absolute trash. I get horrible speeds and terrible range, given every device in my house is at the minimum 802.11n with dual band support. Yet everything works fine when connected via ethernet.

 

I have purchased an ASUS RT-AC68U to use with the Huawei for better range and speed. However now I find that the Huawei doesn't have a Bridge Mode option anywhere? Yet there is a light for it on the device, and as per Spark's documents for the exact same modem (albeit probably a different firmware), there are instructions on how to switch it to Bridge Mode.

 

Why am I unable to activate this on the VF Huawei HG659?

 

Thanks.


Accepted Solutions
Staff
Posts: 177
Registered: ‎27-10-2009

Re: Huawei HG659 Bridge Mode

[ Edited ]
by Staff ChrisVF Staff
Message 14 of 78 (24,034 Views)

Hi,

Here's the guts of setting up bridge mode, will try to get this written up a bit nicer (@MikeHales?). This method will give you full bridge mode as well as a reserved IP to access from another LAN port. Supports VDSL, Fibre and FibreX, does not support ADSL.

 

  1. Disconnect the WAN connection (VDSL or ethernet to ONT / cable modem)
  2. Connect your PC via cable directly to the HG659.
  3. Log on as Admin (not vodafone).
  4. Internet -> Internet Settings: Delete all of the profiles except the connection you want (eg internet_ethernet)
  5. Internet -> Internet Settings: Edit that profile, change connection type to Bridged, change Service type to Internet only (untick TR069 & Voice). It will show disconnected, don't worry about that.
  6. Internet -> Network security -> Firewall: disable the firewall
  7. Home Network -> WLAN settings -> WLAN Encryption: Untick the 2.4 & 5GHz WLAN SSID on the WLAN encryption section. Doing it here rather than under the Basic Settings means that the physical button on the unit won't reenable wifi.
  8. Home Network -> LAN Interface: Turn off UPNP, IPv6 DHCP Server and DHCP Server (IPv4)
  9. You should still be connected. If not, you'll need to set your PC to a static IP in the 192.168.1.0/24 range, eg 192.168.1.123
  10. Home Network -> LAN Interface -> LAN Interface Settings: Set a LAN IP, say to 192.168.200.200 that won't conflict with anything.
  11. Now if you ever want to reconnect to the router, you'll need to set a static IP on your computer to something like 192.168.200.100/24, and connect physically into the router, and browse to 192.168.200.200.

Yell out if you have any problems or if something is unclear.

/chris

View solution in original post

Solution
Accepted by AhmedA (Vodafone Ninja)
‎02-09-2016 03:59 PM

All Replies
Retired Staff
Posts: 3,381
Registered: ‎21-08-2010

Re: Huawei HG659 Bridge Mode

by Retired Staff Dylan Retired Staff
Message 2 of 78 (28,650 Views)

Hi @mmd 

 

Would you be able to disable dhcp and nat on the Asus, and allow the HG659 to cover those?


Cheers

 

Dylan

New Poster
Posts: 1
Registered: ‎12-12-2014

Re: Huawei HG659 Bridge Mode

by voda_user New Poster
Message 3 of 78 (28,632 Views)

Hello,

 

I have a HG659 modem in one end of the house on an ADSL connection. In the middle of the house I have a cisco linksys router which is connected to a main hub that supplies internet to different data ports to the rest of the house. On the other end of the house I have another HG659 connected to a data port and I am trying to setup this as a router. I dont seem to change the internet connection type from internet to bridged so that I can just use this as a wireless router.

 

Is this possible as all by any chance. The modem does have a WAN port that I am connecting to the data port but does not seem to get any internet access.

New Poster
Posts: 1
Registered: ‎18-03-2015

Re: Huawei HG659 Bridge Mode

by dillsqqqq New Poster
Message 4 of 78 (28,366 Views)

You need to log in with the Admin user not the vodafone user it will give u full access,

 

       Username - Admin   

       Password - VF-NZhg659

 

then u can change the internet type in the the internet tab under the VDSL settings.

 

Starter Poster
Posts: 2
Registered: ‎03-04-2015

Re: Huawei HG659 Bridge Mode

by Mash Starter Poster
Message 5 of 78 (28,183 Views)
Posted from Apple iPad
Starter Poster
Posts: 2
Registered: ‎03-04-2015

Re: Huawei HG659 Bridge Mode

by Mash Starter Poster
Message 6 of 78 (30,786 Views)
Posted from Apple iPad
New Poster
Posts: 1
Registered: ‎14-05-2015

Re: Huawei HG659 Bridge Mode

[ Edited ]
by Arlo New Poster
Message 7 of 78 (27,727 Views)

Hi Mash, (sorry about my bad english)

but I don't think so that it's the solution!

I have the HG659 and I'm looking for a real solution to make this modem working in bridge mode!

I was able to switch it (as bridge) but I was not able to make the router working.

I follow the only serius instruction I found online from SPARK and seem for most the people (in Spark) this working fine

but not with the Vodafone connection nd the modem are the same.

 

Anyone has the real solution.

Thanks

 

Retired Staff
Posts: 3,381
Registered: ‎21-08-2010

Re: Huawei HG659 Bridge Mode

by Retired Staff Dylan Retired Staff
Message 8 of 78 (27,680 Views)

Hi Arlo

 

I do not think the HG659 supports full bridge mode. However you may be able to add another router to your network as a wireless access point by disabling DHCP and NAT, and setting a static IP on the second router.


Thanks

 

Dylan

Starter Poster
Posts: 6
Registered: ‎10-01-2016

Re: Huawei HG659 Bridge Mode

by michaelemery Starter Poster
Message 9 of 78 (25,614 Views)

This is not the solution to the problem that is being asked, so it is really irritating that Vodafone staff just delare it to be solved when they don't even understand the problem.

 

I phoned Vodadfone on numerous occasions, and despite being escalated to a number of "technical" teams, I could not find anyone who even understood what bridging means. Very unimpressive for a telecommuications company.

 

While the Huawei is a dreadful router, we need it to make the connection to the Vodadone network, and that is ALL we want it to do. Entrusting DHCP and NAT to the Huawei is the exactly opposite of what we want to achieve. Control of DHCP and NAT settings are required for the important network management features that we would rather do on our own routers (because they are much better at it and more reliable).

 

To "solve" the problem, you need to:

 

a) explain in detail how to set bridging mode on the Huawei, and

b) list the settings (and their values) that need to be configured on the second router.

 

I would not expect Vodafone to explain how to reconfigure someone elses router in any kind of step-by-step detail, but I would expect them to be able to list the settings (in generic terms) and values.

 

So... problem still NOT solved.

 

Starter Poster
Posts: 3
Registered: ‎10-07-2016

Re: Huawei HG659 Bridge Mode

by jerry_nz Starter Poster
Message 10 of 78 (23,339 Views)

i have the exact same problem as the owner of this thread (even the exact same router) and would also count this thread as not solved.

 

hello vodafone... throw us a bone here?

Stats
  • 77 Replies
  • 2y ago
  • 28,683 Views
  • 10 Kudos
  • 15 Contributors
Kudos 101- Don't be shy, hand it out today