Reply

No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

Starter Poster
Posts: 8
Registered: ‎14-01-2016
Accepted Solution

No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

by jackyan Starter Poster
Message 1 of 14 (7,953 Views)

Hi there:

I haven’t been able to find an exact parallel so I thought I’d start a new thread.

 

I have a Meizu M2 Note bought overseas, but before I did, I checked the Wikipedia page (yes, I know) on VFNZ and made sure the frequencies were covered.

 

Everything works fine, including calls and texts, but I cannot get mobile internet on 3G and 4G. Wifi is OK.

 

The M2 works on Lollipop (Android 5.1). I had a single SIM put in by Vodafone in Courtenay Place. The phone has the following settings:

 

Card 1: Absent
Card 2: vodafone NZ >

 

The submenu:

  • Enable: On
  • Edit SIM card name: vodafone NZ
  • Enter phone number: I have put this in, in the +6421xxxxxx format.

Mobile Networks

Mobile data: Card2 - vodafone NZ

  • Mobile data: On
  • Select SIM card
  • Card2 - vodafone NZ (tick)

Network mode: 3G first [this was on 4G first by default]

 

Data roaming >

  • Card 2- vodafone NZ (tick)

Other
Portable hotspot

  • Portable hotspot: off
  • WLAN sharing
  • Portable Wi-fi hotspot: on
    WPA2 PSK encrypt
  • Other sharing
    Bluetooth tethering: off
    USB network sharing: off

VPN: off
PPPoE dial-up: disconnected
APNs

  • Card2 - vodafone NZ >
  • VFNZ internet
    www.vodafone.net.nz
    Name: VFNZ Internet
    APN: www.vodafone.net.nz
    Proxy:
    Port:
    Username:
    Password:
    Server:
    MMSC:MMS proxy:
    MMS port:
    MCC: 530
    MNC: 01
    Authentication type: PAP [this was on none by default; I only changed it after browsing one of the threads; neither works]
    APN type: default,supl
    APN protocol: IPv4
    Enable APN: on
    Bearer: Unspecified
  • VFNZ PXT
    live.vodafone.com
    Name: VFNZ PXT
    APN: live.vodafone.com
    Proxy:
    Port:
    Username:
    Password:
    Server:
    MMSC: http://pxt.vodafone.net.nz/pxtsend
    MMS proxy: 172.30.38.3
    MMS port: 8080
    MCC: 530
    MNC: 01
    Authentication type: None
    APN type: mms
    APN protocol: IPv4
    Enable APN: on
    Bearer: Unspecified

Network operator

  • Card2 - vodafone NZ
    Operator
    Auto

    [After a while searching, these come up:]
    VodafoneNZ 3G (tick)
    current
    VodafoneNZ 2G
    available
    Telecom NZ 3G
    forbidden
    2degrees 3G
    forbidden
    2degrees 2G
    forbidden

    [Earlier on, there was a VodafoneNZ 4G option with ‘available’ underneath.]

Push: off

Hope someone can shed some light on what the error might be.


Thank you,

Kind regards,

 

Jack

 

 

 

 

 

 

 

 


Accepted Solutions
Highlighted
Starter Poster
Posts: 8
Registered: ‎14-01-2016

Re: No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

[ Edited ]
by jackyan Starter Poster
Message 8 of 14 (12,872 Views)

Good news, Jack at the Courtenay Central store sorted it. There was one line that was incorrect as I’m from the blue side of the business (which I had mentioned on my initial visit to the store and when calling support via the telephone). Online now, thank you all!

View solution in original post

Solution
Accepted by topic author jackyan
‎15-01-2016 04:45 PM

All Replies
Retired Staff
Posts: 1,012
Registered: ‎19-10-2014

Re: No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

by Retired Staff Lucas Retired Staff
Message 2 of 14 (7,948 Views)

Hi @jackyan,

 

You'll need to change the APN name to "vodafone". Then restart your phone

I work in the Mobile On Account and Mobile Technical Support team. I volunteer my time on the Community.
Starter Poster
Posts: 8
Registered: ‎14-01-2016

Re: No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

by jackyan Starter Poster
Message 3 of 14 (7,941 Views)

Thanks, Lucas. No joy. Smiley Sad Also when I look more deeply into the settings, it says ‘Mobile network state: disconnected’. Do you reckon this is the Vodafone end?

Interestingly, the GPS seems to be working fine (i.e. when I take a photo it knows the location), and I have the five bars up top with the little 3G symbol.

Business Ninja Adept
Posts: 1,509
Registered: ‎30-09-2014

Re: No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

by Business Ninja Adept Business Ninja Adept Business Ninja Adept
Message 4 of 14 (7,931 Views)
@Lucas APN is not the issue www.vodafone.net.nz will work just fine.

@jackyan have you tried the SIM in another handset and did data work for you? May pay to also try the SIM in slot one.

Cheers
NOC Engineer | Vodafone NZ
Posted from Apple iPhone
Starter Poster
Posts: 8
Registered: ‎14-01-2016

Re: No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

by jackyan Starter Poster
Message 5 of 14 (7,924 Views)

Thank you, Sebastian. I haven’t tried another device as this is the only one I have that uses a nano-SIM. At the moment I have a micro-SD in slot one—I can give it a go though.

Business Ninja Adept
Posts: 1,509
Registered: ‎30-09-2014

Re: No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

by Business Ninja Adept Business Ninja Adept Business Ninja Adept
Message 6 of 14 (7,903 Views)
No problem , part of basic fault checking this way you find if the problem is on the Vodafone NZ end or if the fault is handset related.

Cheers
NOC Engineer | Vodafone NZ
Posted from Apple iPhone
Starter Poster
Posts: 8
Registered: ‎14-01-2016

Re: No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

by jackyan Starter Poster
Message 7 of 14 (7,878 Views)

Hi Sebastian: thank you. I gave it a whirl, but no joy on slot 1 either. I might pop in to the Vodafone shop this afternoon and see if one of the guys there can figure it out.

Highlighted
Starter Poster
Posts: 8
Registered: ‎14-01-2016

Re: No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

[ Edited ]
by jackyan Starter Poster
Message 8 of 14 (12,873 Views)

Good news, Jack at the Courtenay Central store sorted it. There was one line that was incorrect as I’m from the blue side of the business (which I had mentioned on my initial visit to the store and when calling support via the telephone). Online now, thank you all!

Solution
Accepted by topic author jackyan
‎15-01-2016 04:45 PM
Business Ninja Adept
Posts: 1,509
Registered: ‎30-09-2014

Re: No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

by Business Ninja Adept Business Ninja Adept Business Ninja Adept
Message 9 of 14 (7,851 Views)
@jackyan yes the Blue (TCL) APN is different from that of Regular 'red' customers. Sorry that that wasn't picked up if you'd mentioned that you were an exTCL customer.

Glad to hear it's all working for you now :-).
NOC Engineer | Vodafone NZ
Posted from Apple iPhone
Starter Poster
Posts: 8
Registered: ‎14-01-2016

Re: No internet on 3G and 4G, everything else is OK (Meizu M2 Note running Lollipop)

by jackyan Starter Poster
Message 10 of 14 (6,597 Views)

Hi guys, I thought I’d carry on this thread since this bug has resurfaced.

Last month, I was finally ported over to the red side of the business. I was given a new SIM, which I put in to my phone, and other than calling Vodafone to advise them that the account should be activated, I didn’t do anything. I imagine the correct APN installed by itself, and the 3G symbol that I was used to seeing under TelstraClear became a 4G LTE one. So far so good.

 

Last weekend, the Meizu OS upgraded. It’s still Lollipop, just with a better skin and more functionality. Everything was still fine, except I noticed that I wasn’t seeing a 4G symbol any more. It had turned back to 3G.

 

However, everything worked, it just wasn’t at the highest speed (I guess).

 

Out of curiosity, I wanted to get the 4G back and noticed that the APNs for both the old TelstraClear set-up and the new Vodafone one were there. I deleted the TelstraClear one, which two Vodafone staff now say was what they would have done, too. Problem: while the symbol now says 4G, I have no mobile internet. Basically I’m back to square one on when I posted on this board in January.

Since a store visit was successful in January, I did the same this time, but Richard at Cuba Street tried plenty of permutations without any joy. He advised me to call tech support, and I spoke to Shafeel, and we even went to the extreme of adding back the TelstraClear APN to run alongside the correct Vodafone one. Also no joy. He suggested I return to the store. Richard gave it another go, put his own SIM in there, but nada. He then said he would talk to a Vodafone ninja and I would get a call today—but it’s now quarter to midnight, no call.

I visited the Lambton Quay store, and you can guess it was the same story.

I’ve gone through the official APN settings as posted on this board, to no avail.

Now, I know I have a 4G signal. The phone has one international roaming service that depends on some in-built feature, not the Vodafone APN, and that connects through mobile. I go between 4G and 3G zones in Wellington and the symbol changes. It’s got the right strength. Wifi is fine. What gets me is that for the first day of the upgraded OS, I could surf using mobile data (and have the used megabytes to show for it!), yet by deleting the unused APN, I lose it.

I’ve spent two to three hours going to and from and being at Vodafone shops these last two days and over half an hour with Shafeel.

I’m almost tempted to stick back the obsolete TelstraClear SIM card, putting the old APN in (which I know won’t work), then put in the new Vodafone SIM, just to get the two APNs side by side again and seeing if it works. I know that’s stupid but I’m running out of ideas. Any help would be welcome.

Stats
  • 13 Replies
  • 1y ago
  • 7,954 Views
  • 3 Kudos
  • 3 Contributors
Kudos 101- Don't be shy, hand it out today